Forum: WHALER
  ContinuousWave
  Whaler
  Moderated Discussion Areas
  ContinuousWave: Whaler Repairs/Mods
  Garmin/168/download

Post New Topic  Post Reply
search | FAQ | profile | register | author help

Author Topic:   Garmin/168/download
Ed Stone posted 12-30-2000 08:24 PM ET (US)   Profile for Ed Stone   Send Email to Ed Stone  
I've been trying to download info from a
mapsource CD onto my garmin.Our computer
will not recognize the garmin.If all else
fails I guess I should read the instructions.
Any help would be appreciated.
triblet posted 12-31-2000 08:37 PM ET (US)     Profile for triblet  Send Email to triblet     
I've got a 162 which is the same unit less
the sonar. Mapsource downloaded no muss
no fuss.

What kind of computer do you have? What
operating system? There
have been lots of reports of problems with
some flavor Dell computers with Windows 2000.

Do you have the genuine Garmin PC cable?
Are you supplying 12V to the GPS? Does it
turn on?

Did you set the GPS to Menu, Menu, Comm,
Garmin Data Transfer? What speed did you
set it to?

Most importantly, what do you mean by "does
not recognize"? What is the exact text of
the error messages?

I know some of this sounds like dumb
questions, but they gotta be asked.

Chuck Tribolet

Ed Stone posted 01-01-2001 09:19 PM ET (US)     Profile for Ed Stone  Send Email to Ed Stone     
Hey Chuck,
We have a compaq computer with a AMD chip.
The message stated unable to find gps.
I have the factory PC transfer cable.
I went to prefrences in the edit file &
entered auto detect.I turned on the gps
and had to put it on simulator.The antenna
is mounted on the boat.
Thanks,I'll talk to ya later
triblet posted 01-02-2001 12:35 AM ET (US)     Profile for triblet  Send Email to triblet     
Do other things work on that serial port?

You shouldn't have to set simulator (and that
may disable comms). I just keep selecting
reinitialize or some such, and it keep trying
to find the sats without an antenna, but
download works OK.

You didn't answer:
Did you set the GPS to Menu, Menu, Comm,
Garmin Data Transfer? What speed did you
set it to?

Chuck Tribolet

jimh posted 01-02-2001 01:23 PM ET (US)     Profile for jimh  Send Email to jimh     
Serial interconnections can be a bug-a-boo.

The basic problem is that the terms "receive data" and "transmit data" are only definable in terms of the perspective of the device sending or receiving.

At some point in a serial data connection, there has to be a twist in the wiring, so that the "transmit data" from the sender will arrive at the "receive data" terminal of the reciever.

This twist can either be accomplished with a specially wired cable, or if the equipment is wired to accomodate it.

In serial communications, devices are designated as either DTE or DCE devices.

DTE--Data Terminal Equipment

DCE--Data Commmunications Equipment

A PC is usually wired as a DTE device.

A modem is usually wired as a DCE device.

Thus, if you connect a PC and a Modem you can use a cable that is wired "straight through."

If you try to connect two devices that are both wired as DTE devices, your interconnecting wiring must accomplish the twist, i.e., connect the send to the receive and vice versa.

I would suspect that in the case of a GPS device and a PC, both are likely wired as DTE, and thus must be interconnected with a specially wired cable.

This simple error in wiring would explain the non-functioning of the serial interface.

It may seem stupid to have to buy a "special cable" but in this case I suspect that is what is needed to get the two serial devices to talk to each other.

Incidently, this is such a common situation that an adapter is available to accomplish the twist. Since the adapter replaces the communication link--formerly accomplished with modems--it is known as a NULL MODEM ADAPTOR.

--jimh

triblet posted 01-02-2001 02:00 PM ET (US)     Profile for triblet  Send Email to triblet     
He's using the standard Garmin PC cable which
is wired correctly.

Mmmm, maybe Ed has a bad cable. Can you
borrow another one?


Chuck Tribolet

jimh posted 01-02-2001 07:49 PM ET (US)     Profile for jimh  Send Email to jimh     
If the wiring is correct, there are still plenty of traps in a serial connection.

Check that both devices are matching:

--baud rate
--parity bit
--stop bit
--data bit length

Then at higher levels, check that the data format is the same, the session protocols are matching, the host/client protocols are correct.

It sometimes can take a whole day to debug one of these things...I know!

--jimh

Ed Stone posted 01-02-2001 09:37 PM ET (US)     Profile for Ed Stone  Send Email to Ed Stone     
Yes I tried menu,comm,garmin data transfer,
And to reinitialize gps.Then I went to the
edit page and to prefrences and clicked auto
detect,IT says searching com2 and then says
unable to find gps.I tried com1 thru com8,
it always says searching com2 then unable
to find.I uninstalled map source then
reinstalled,same window unable to find.

Hey Jimh ,Thanks but you lost me.

Chuck I did not find the transfer speed.
Thanks I'll keep trying.

triblet posted 01-03-2001 10:13 AM ET (US)     Profile for triblet  Send Email to triblet     
Jimh: all that stuff is hard coded into
MapSource. Both the GPS and the SW came
from Garmin, so you would think they got
it right.

Ed: the transfer rate is set in on the
GPS Comm menu page where you set Garmin
Data Transfer. But it may be greyed out
for Garmin Data Transfer and only available
for RTCM and such.

I think this is coming down to a couple of
possibilities:

- bad cable

- serial port not enabled in the BIOS

- operating system not setup for serial port
(but unlikely as MapSource finds the serial
port, just doesn't find the GPS.

It looks like your computer has two serial
ports -- can you try the other one?

Chuck

Reliant posted 01-03-2001 02:05 PM ET (US)     Profile for Reliant  Send Email to Reliant     
Ed – I suspect that your computer has an internal modem, which will be using one of the comm. Ports. I bring this up, as you do not want to make any changes in your CMOS setup that will do you out of your modem. You can check on what comm. port your modem is using by clicking on Start>Settings>Control Panels and then double clicking on the modem control panel and then clicking on the properties button once your modem is highlighted. If you do not have a modem, please disregard my babbling.

Usually with internal modems, on of the serial ports is disabled in CMOS to free up the resources for the modem. If yours is like other Compaq’s I have seen, you probably have only one physical comm. port on the back of the computer. First of all as triblet pointed out, is your comm. port enabled in CMOS. You can get into CMOS setup on most Compaqs by hitting the F10 key repeatedly when you first turn on the computer until you see the message “Entering system setup” or something similar. Go through the various menus and make sure that at least one comm. port is enabled.

Question – If the comm. Port is enabled, have you been using it for something else like synchronizing a palm pilot with the computer? The Palm Pilot for instance has a piece of software called the Hot Sync manager, which will “camp-out” on the comm. Port waiting to see if you want to synchronize with the Palm Pilot. While the Hot Sync Manager is running, you will not be able to use the comm. port for anything else.

Hope this helps,

Peter Ferguson

Ed Stone posted 01-03-2001 09:52 PM ET (US)     Profile for Ed Stone  Send Email to Ed Stone     
Hey peter,
Yes I did disconect My wifes 9 pin connector
that feed her palm pilot so I could hook up
My gps.And yes I did catch heat from her for
that.(I catch alot of heat since she got
pregnant)How can I bypass that palm pilot?
Thanks for the help.
Ed Stone
Reliant posted 01-04-2001 01:13 AM ET (US)     Profile for Reliant  Send Email to Reliant     
Ed – When you are looking at your desktop on your computer, you should see a small icon with red and blue arrows going in opposite directions in the bottom right of the task bar. This is the icon for the hot synch manager. Right click on it and choose exit from the drop down menu. It will come up with a message that you will not be able to synchronize the palm pilot if you exit the manager. Click on yes to exit the hot synch manager. Hopefully you should know be able to download to your GPS.

To re-enable the hot synch manager, go to Start>Programs>StartUp and click on the Hot Sync Manager icon. If that does not work, reboot the computer. You will need to know this; otherwise, your wife will try and hook up the Palm Pilot cradle and hit the synch button and when nothing happens, go “O.J.” on your ass ;-)

Hope this helps,

Peter Ferguson

Ed Stone posted 01-04-2001 09:05 PM ET (US)     Profile for Ed Stone  Send Email to Ed Stone     
Mapsource download a success!
With the hotsync gone the download was
a piece of cake!Now I have most of fla.
installed on my 168 garmin.

Thanks again everyone for the help.
Ed Stone Fishin-N-Fla.

blackdog posted 01-05-2001 01:48 PM ET (US)     Profile for blackdog  Send Email to blackdog     
Wow,
You guys just saved me from a big agrument with my wife. She has a palm and I am going to buy the 162....
Thanks!!!! I get to stay out of the dog house for atleast one day.

Blackdog

Post New Topic  Post Reply
Hop to:


Contact Us | RETURN to ContinuousWave Top Page

Powered by: Ultimate Bulletin Board, Freeware Version 2000
Purchase our Licensed Version- which adds many more features!
© Infopop Corporation (formerly Madrona Park, Inc.), 1998 - 2000.