Forum: WHALER
  ContinuousWave
  Whaler
  Moderated Discussion Areas
  ContinuousWave: Whaler Repairs/Mods
  electrical connections

Post New Topic  Post Reply
search | FAQ | profile | register | author help

Author Topic:   electrical connections
1961bugeye posted 04-16-2001 08:07 AM ET (US)   Profile for 1961bugeye   Send Email to 1961bugeye  
My 1987 Montauk has a problem with my electrical accesories. Sometimes the lights will not turn on. Sometimes the bilge will not turn on etc. If I push and pull on the switches then it might work. Maybe bad connections or switch? What to do?
jameso posted 04-16-2001 09:04 AM ET (US)     Profile for jameso  Send Email to jameso     
Corrosion on the contacts, operate switches more often. Use the boat don't let it sit on the trailer! Seriously I have that problem with my farm equpiment. First thing in spring is remove all lights and clean contacts with small file and operate swtiches, sometimes need to replace switch. On a water craft always use hardware made for BOATS not trains or cars.
Jim Armstrong
triblet posted 04-16-2001 10:58 AM ET (US)     Profile for triblet  Send Email to triblet     
If it's marine grade, you can't get at the
switch contacts. They are sealed in.

You need to determine whether it's the switch
the connnection, or something else. Next
time it happens, don't work the switch.
Leave it on, and start wiggling the wires
connected to it one at a time. I'd probably
also pull each connection off one at a time
and put it back. If feels loose, I'd crimp
down the female connector just a little.

Chuck

Post New Topic  Post Reply
Hop to:


Contact Us | RETURN to ContinuousWave Top Page

Powered by: Ultimate Bulletin Board, Freeware Version 2000
Purchase our Licensed Version- which adds many more features!
© Infopop Corporation (formerly Madrona Park, Inc.), 1998 - 2000.