Forum: WHALER
  ContinuousWave
  Whaler
  Moderated Discussion Areas
  ContinuousWave: Whaler Repairs/Mods
  Electrical ? - 1984 70 hp Evinrude VRO

Post New Topic  Post Reply
search | FAQ | profile | register | author help

Author Topic:   Electrical ? - 1984 70 hp Evinrude VRO
Capt_Tidy posted 07-17-2003 11:40 AM ET (US)   Profile for Capt_Tidy   Send Email to Capt_Tidy  
I'm loving my two new 15s... its a long story. One will be for sale soon.

Evinride questions - 70 hp 1984 VRO....

1. On the port side - wiring connections labelled No. 1 through 5.

I notice the grey lead for No. 2 terminal has been disconnected on mine...

Anybody know what this maybe about.

2. VRO tank... anybody have a detail drawing forthe tankand fitting or can suggest one. I was wantign to test the alarms etc if any?

cheers
Ian

Capt_Tidy posted 07-22-2003 12:28 AM ET (US)     Profile for Capt_Tidy  Send Email to Capt_Tidy     
No body has a mid 80 70 hp Johnson or Evinrude around? Amazing.
Steve Leone posted 07-22-2003 01:07 AM ET (US)     Profile for Steve Leone  Send Email to Steve Leone     
Grey is generally the tachometer. Ground the sensor on the block to test the temp sensor. Ground the lead from the oil tank to test the oil alarm. Steve

Post New Topic  Post Reply
Hop to:


Contact Us | RETURN to ContinuousWave Top Page

Powered by: Ultimate Bulletin Board, Freeware Version 2000
Purchase our Licensed Version- which adds many more features!
© Infopop Corporation (formerly Madrona Park, Inc.), 1998 - 2000.