Forum: WHALER
  ContinuousWave
  Whaler
  Moderated Discussion Areas
  ContinuousWave: Whaler Repairs/Mods
  Trim/Tilt "Clicking Noise"???

Post New Topic  Post Reply
search | FAQ | profile | register | author help

Author Topic:   Trim/Tilt "Clicking Noise"???
Outrage18 posted 10-27-2003 02:23 PM ET (US)   Profile for Outrage18   Send Email to Outrage18  
Hello-

I have a 1995 150 Mecury Black Max, that clicks when going both up and down in the same spot. What could cause this noise?(Is it the relay?) And How hard is it to replace the gaskets to repait the old leaky trim problem?(It falls down after being tilted up for the night)
Right now I just flip up the mechanical lever that holds the engine up....

Any advice??
Thanks!!!

-Paul

Bigshot posted 10-27-2003 02:44 PM ET (US)     Profile for Bigshot  Send Email to Bigshot     
Clicking is usually the pivot point hwere the tilt ram meets the engine's midsection, not in the pump. The leaking down is either an external seal leak whuch would require adding fluid and may be a cause of the clicking. Or an internal check valve that does not leak oil and requires a trim assembly overhaul to replace a $1 part. If the latter I would continue to use the tilt bar overnight until it gets worse.
Outrage18 posted 10-28-2003 02:52 PM ET (US)     Profile for Outrage18  Send Email to Outrage18     
Thanks BigShot!

Anyone else want to share their knowlege of Trim/Tilt repairs?

Thanks in Advance

_paul

Swellmonster posted 10-30-2003 07:58 AM ET (US)     Profile for Swellmonster  Send Email to Swellmonster     
My merc has the two rolling balls on the ends of the rods that contact the motor. They get sticky and sandy and slow and go clicky. I regrease them then they are happy for a while.

Post New Topic  Post Reply
Hop to:


Contact Us | RETURN to ContinuousWave Top Page

Powered by: Ultimate Bulletin Board, Freeware Version 2000
Purchase our Licensed Version- which adds many more features!
© Infopop Corporation (formerly Madrona Park, Inc.), 1998 - 2000.