Forum: WHALER
  ContinuousWave
  Whaler
  Moderated Discussion Areas
  ContinuousWave: Whaler Performance
  13'Whaler with charging Problems

Post New Topic  Post Reply
search | FAQ | profile | register | author help

Author Topic:   13'Whaler with charging Problems
HobieOne posted 04-22-2003 10:19 PM ET (US)   Profile for HobieOne   Send Email to HobieOne  
have a 13 with a Merc 50 that the previous owner had hooked to a bank of 2 deep cycle bats for a trolling motor. It took a full season before I notice that it didn't charge. One mech told me that that much battery will overtax the charging system and burn it out. It appears he knows his stuff. what he couldn't tell me is WHAT is burned out. I hear there's a rectifier in there (converts the AC to 12V DC) and a stator (that I assume gens the AC). Anybody know how to tell which got fried? Any body know how much of my tax refund this may eat up?
jimh posted 04-23-2003 09:07 AM ET (US)     Profile for jimh  Send Email to jimh     
This is really more of a repair or modification issue than a performance question, and probably better asked in the REPAIR and MODs forum. As long as we are here...

A rectifier for my 1976 50-HP Mercury, an OEM part from a retail dealer, was about $35.

A stator will be more expensive, perhaps $200-300, and it will require removal of the flywheel to repair. Removal of the flywheel can be difficult without certain specialized tooling to assist.

There are many references to stator replacement in the archives. Here is one:

http://continuouswave.com/ubb/Forum3/HTML/001605.html

Use the site search to locate more.

http://continuouswave.com/htdig/

Post New Topic  Post Reply
Hop to:


Contact Us | RETURN to ContinuousWave Top Page

Powered by: Ultimate Bulletin Board, Freeware Version 2000
Purchase our Licensed Version- which adds many more features!
© Infopop Corporation (formerly Madrona Park, Inc.), 1998 - 2000.