Forum: WHALER
  ContinuousWave
  Whaler
  Moderated Discussion Areas
  ContinuousWave: Small Boat Electrical
  Northstar 6000i

Post New Topic  Post Reply
search | FAQ | profile | register | author help

Author Topic:   Northstar 6000i
bermuda blues posted 01-19-2006 09:34 AM ET (US)   Profile for bermuda blues   Send Email to bermuda blues  
I'm looking for anyone who is running the factory-installed Northstar electronics package [on their Boston Whaler boat]. I just wanted to know how you like it? Have you had any problems? Also, [seeking opinions on] any radar/gps/sounder for my new 320 OUTRAGE. Thanks for the help
sail16 posted 01-19-2006 10:21 AM ET (US)     Profile for sail16  Send Email to sail16     
I'm not running the entire package-- just the 6000i 8-inch GPS. I have absolutely nothing but positive things to say about the unit-- beautiful display, very clear interface, all the standard bells and whistles. The only downside I've seen is [cost].
bluewaterpirate posted 01-19-2006 06:28 PM ET (US)     Profile for bluewaterpirate  Send Email to bluewaterpirate     
Here you go: I have the package on my 235 Conquest. The Northstar 6000i is a great chartplotter. It has a nice crisp display. I cannot say that I'm impressed with the fishfinder side of it. The NAVMAN radio is good, but I replaced it with an ICOM 502A and use it as a backup. The Northstar is tied in with the Smart Craft System.

http://home.earthlink.net/~bluewaterpirate/sitebuildercontent/ sitebuilderpictures/6000iwhaler.jpg

http://home.earthlink.net/~bluewaterpirate/sitebuildercontent/ sitebuilderpictures/6000i.smart.jpg

Tom

tyler993 posted 03-15-2009 09:31 AM ET (US)     Profile for tyler993  Send Email to tyler993     
I just bought a used Whaler with a Northstar 6000i. I'm looking for an instructional or training video for the unit. Any suggestions?
djtdmd posted 11-29-2009 11:22 PM ET (US)     Profile for djtdmd  Send Email to djtdmd     
The 6000i is a good unit, but Whaler often incorrectly mounts the transducer at the factory. I have posted some of my experiences about tis on the forum. Once mounted in the right spot, the sounder works great but I am getting some engine interference marks on the display only when the engines are on. If I put on the noise limiter on the 6000i, it goes away. Hope this helps...

Post New Topic  Post Reply
Hop to:


Contact Us | RETURN to ContinuousWave Top Page

Powered by: Ultimate Bulletin Board, Freeware Version 2000
Purchase our Licensed Version- which adds many more features!
© Infopop Corporation (formerly Madrona Park, Inc.), 1998 - 2000.