Moderated Discussion Areas
  ContinuousWave: Small Boat Electrical
  Electrical hook-up for a Sci-Tek Chart Plotter

Post New Topic  Post Reply
search | FAQ | profile | register | author help

Author Topic:   Electrical hook-up for a Sci-Tek Chart Plotter
brucemac posted 06-24-2007 07:38 AM ET (US)   Profile for brucemac   Send Email to brucemac  
I have a 22 foot 1980 Whaler Revenge i/o. JUst bought a sci-tek Navmate chart plotter. Wiring diagram shows red wire to power, black to ground, as expected. I wired the red lead to a terminal (on the power block behind the helm console) on the red side, beyond a fuse ( ie fuse is in the circuit). The fuse looks ok. I wired the black lead inot the ground side of the power bar. However, with this wiring, no power arrives at the chart plotter under any condition. Any thoughts on this?
Chuck Tribolet posted 06-24-2007 09:19 AM ET (US)     Profile for Chuck Tribolet  Send Email to Chuck Tribolet     
Do you know that you have power and ground on the bus bar? Do other
things attached to it work? Have you checked it with a


bluewaterpirate posted 06-24-2007 11:30 AM ET (US)     Profile for bluewaterpirate  Send Email to bluewaterpirate     
Check the fuse .... make sure the fuse holder is securely snapped shut. That glass fuses are the weakest link in your connectivity.


brucemac posted 06-24-2007 09:29 PM ET (US)     Profile for brucemac  Send Email to brucemac     
Thanks for the replies. I ow have a further mystery re sci-tek plotter. I got it up and running by checking the fuse in the circuit I had chosen, (pretty much at random since it was one with not too many connections)
and the fuse was broken. I replaced it with a 30 amp marine fuse and presto the plotter came on. The situation was that I was at the dock, and had the battery switch turned to both batteries. Things were golden. I worked with it for a while learning some of the features. I shut down and left for a few hours. When I returned I fired up the boat and took her out, I mounted the plotter, pressed the power button and I got nothing. I Checked the fuse and it is OK. So I unpowered the thing, hoping that I hadn't somehow fried it. When I got back to the dock, I shut down the engine, left the batteries on, tried powering up the sci-tek and I got nothing. Fuse is OK. Connections OK. Any thoughts on what might be going on?
Chuck Tribolet posted 06-25-2007 08:39 AM ET (US)     Profile for Chuck Tribolet  Send Email to Chuck Tribolet     
This isn't your problem, but 30 Amp is probably too big. You
fuse based on the wire size, and 30 Amp is appropriate for
about 10 ga wire.

As far as your current problem, the stuff in my prior post
still applies.


Post New Topic  Post Reply
Hop to:

Contact Us | RETURN to ContinuousWave Top Page

Powered by: Ultimate Bulletin Board, Freeware Version 2000
Purchase our Licensed Version- which adds many more features!
© Infopop Corporation (formerly Madrona Park, Inc.), 1998 - 2000.