Forum: WHALER
  ContinuousWave
  Whaler
  Moderated Discussion Areas
  ContinuousWave: Small Boat Electrical
  Clarion stereo - no sound

Post New Topic  Post Reply
search | FAQ | profile | register | author help

Author Topic:   Clarion stereo - no sound
mtwilling posted 07-05-2010 11:05 PM ET (US)   Profile for mtwilling   Send Email to mtwilling  
The Clarion stereo in my '04 Dauntless has stopped working properly. It will power up, change channels, and play a CD but produces no sound whatsoever. I have checked speaker connections, fuses, and all cabling and connections and find nothing wrong. Any advice? My guess is I am better off replacing it than spending money on a repair.
davej14 posted 07-06-2010 09:31 AM ET (US)     Profile for davej14  Send Email to davej14     
Do you have a headphone jack? Try plugging and unplugging headphones a few times. If the output to the speakers is blown then replace the radio, a repair will not be cost effective.
K Albus posted 07-06-2010 09:35 AM ET (US)     Profile for K Albus  Send Email to K Albus     
How many speakers do you have? If you have only two, check the "Fade" setting on your stereo to make sure the power is going to the right set of speakers (either front or rear).
mtwilling posted 07-06-2010 10:51 PM ET (US)     Profile for mtwilling  Send Email to mtwilling     
Good thought on the fade setting. I have just two speakers so that is possible. Thanks.
contender posted 07-08-2010 09:47 AM ET (US)     Profile for contender  Send Email to contender     
mtwilling, if you have a stereo capable of four speakers, try changing the wires to the other two speaker connections out of the stereo, sometimes one side will blow(bad diode in the radio) out but the other side will be ok...
cspaldi posted 07-12-2010 01:43 PM ET (US)     Profile for cspaldi  Send Email to cspaldi     
We have a 2004 Dauntless 220 with EXACTLY the same problem with the factory radio (4 factory speakers). I have not looked into the problem yet but would love to hear if you have determined the cause. Thanks.
bill4tuna posted 08-22-2010 10:42 PM ET (US)     Profile for bill4tuna  Send Email to bill4tuna     
same problem with the clarion stereo. power to the radio but will not come on. no power from fuse yellow wire from the radio. 255 conquest. how do i remove the radio?
davej14 posted 08-23-2010 08:13 AM ET (US)     Profile for davej14  Send Email to davej14     
bill4tuna,

Can yo be more specific? Are you saying that there is no power to the radio from the fuse block? Did you look for an inline fuse in the radio power lead between the fuse block and the radio? Sometimes the original inline fuse is left in place when the radio is installed and it could have blown.

tesija posted 08-26-2010 10:19 PM ET (US)     Profile for tesija  Send Email to tesija     
Mine has a removable face-for anti theft purposes. A red LED light glows when the radio face is removed indicating power, but when its installed back-no power.
bill4tuna posted 08-27-2010 05:05 PM ET (US)     Profile for bill4tuna  Send Email to bill4tuna     
there is power to the radio and the 2amp fuse is not blown as tested with my multimeter but radio will not come on. there is also a helm remote " on" switch but nothing there either. I have a garmin 3200 fishfinder with XM radio signal that plays through the radio. Does this have anything to do with the radio not working. It worked before?
bill4tuna posted 08-27-2010 05:06 PM ET (US)     Profile for bill4tuna  Send Email to bill4tuna     
any tech advice to remove the clarion radio?
bill4tuna posted 08-27-2010 06:12 PM ET (US)     Profile for bill4tuna  Send Email to bill4tuna     
found owners manual. there is a reset button behind removable face. will check on next visit to boat. hope this helps.

http://www.clarion.com/us/en/MungoBlobs/422/878/CZ109_ENG.pdf

tesija posted 08-29-2010 10:12 PM ET (US)     Profile for tesija  Send Email to tesija     
Link doesn't work
davej14 posted 08-30-2010 04:31 PM ET (US)     Profile for davej14  Send Email to davej14     
http://www.clarion.com/us/en/MungoBlobs/422/878/CZ109_ENG.pdf
davej14 posted 08-30-2010 04:55 PM ET (US)     Profile for davej14  Send Email to davej14     
bill4tuna,

If the reset does not work then I would directly connect the radio to your battery and see if it will come on. Your comment about a remote switch at the helm that also does not have power is confusing.

How does the Garmin unit play through the radio? If it is an FM link without a direct connection it would not have anything to do with the radio power or sound.

I wouldn't pull the radio until I tried it with a simple direct connection.

hc803 posted 09-01-2010 10:02 AM ET (US)     Profile for hc803  Send Email to hc803     
It could be that the amplifier portion of the radio is bad. And yes, it's easier to replace than repair cost-wise. One thought I had is that Clarion's 2-speaker installation instructions have you hook up only the front 4 speaker wires, and not all 8. I'd just double-check to make sure you only have those wires connected, as it could be shorting out otherwise.

Post New Topic  Post Reply
Hop to:


Contact Us | RETURN to ContinuousWave Top Page

Powered by: Ultimate Bulletin Board, Freeware Version 2000
Purchase our Licensed Version- which adds many more features!
© Infopop Corporation (formerly Madrona Park, Inc.), 1998 - 2000.