Moderated Discussion Areas
  ContinuousWave: Small Boat Electrical
  Lowrance HDS Update Problems

Post New Topic  Post Reply
search | FAQ | profile | register | author help

Author Topic:   Lowrance HDS Update Problems
jimh posted 08-08-2010 05:05 PM ET (US)   Profile for jimh   Send Email to jimh  
Recently I purchased a Lowrance HDS-8 chart plotter, GPS receiver, and SONAR depth sounder. The unit came with version 2.5 of the primary operating system. There has since been an update available to version 3.0.

After installing the device on my boat--I will have more about that topic in a separate article--I deferred applying any update software. I wanted to become familiar with the device and its operation before I started fiddling with upgrades. After a week of cruising I had noticed a few oddities in the behavior of the device, and considering that I had about a 20-day hiatus from boating ahead of me, I figured it was time to apply the upgrade.

The upgrade is a user-installable patch which must be placed on a SD-Memory card. The card is placed in the HDS device, and the power turned on. The HDS then boots from the memory card and runs a updater installer application. It sounds simple enough, doesn't it?

The first step is to acquire the software. I downloaded the approximately 300-megabyte package from LOWRANCE.COM. The fun began. The download website included special instructions to users of the MacOS (like me) to change the file permissions of the download to permit execution. This was no problem for me to accomplish. After a few minutes I had the executable download on my MacOS machine, and by double-clicking it I could begin the update process.

The downloaded file wants to run as a JAVA applet and built the updater package onto your memory card. The first problem began shortly after launching the download. The application needs to have the JAVA framework installed in order to run, so its first mission is to probe the host machine for JAVA. After half a minute of searching, I was informed that the download could not find any instance of a JAVA virtual machine installed. Of course, that was not the case, I do have JAVA on my MacOS machine. I suspect that my version of JAVA was newer than the application was looking for, and it failed to notice the newer JAVA install. (I have seen this before with older JAVA applications. They don't anticipate that the host machine in the future could have a JAVA version that is newer than the one they were created with.) My MacOS machine is running MacOS 10.6.4, the latest version of the operating system. Maybe that was also a problem

Not wanting to give up easily, I tried using another machine I have, a non-Intel processor based MacOS 10.4 computer. Ahah! Success! The Lowrance JAVA applet was glad to run on that computer. I launched the download applet, which then began the task of building the updater. I ran the updater a couple of times, letting it build the update package onto a directory on one of the local hard drives. All seemed to be running well. Next I rigged up my SanDisk memory card reader USB accessory, and re-ran the download JAVA application, letting it build the package on the 2-GB Kingston memory card I inserted into the reader. Writing 300-megabytes to a memory card via USB-1 (on my older machine) takes a while, so I went off to some other tasks. After about ten minutes I returned to find the download JAVA app had ended, but it informed me of errors that had occurred. Maybe the machine had gone to sleep during the extraction and goofed up the process of writing to the memory card. I ran it again, this time occasionally moving the mouse to suppress my screen saver and drive shut-down from occurring. Ten minutes later I had a successful termination of the JAVA app and the updater files written to the memory card.

Now we leave the MacOS behind and go out to the boat to insert the memory card into the HDS-8. I powered the device on, and the updater installation began. After just a few moments, however, the updater stopped. It declared that there was a problem with an update file on the memory card, and it was halting execution. Oh boy, I hoped the HDS-8 was still a $1,700 chart plotter, SONAR, and GPS at this point. It was, but the update had only partially completed. Now I was in a pickle. I had an HDS-8 that seemed to work, but I was leery that there might be some embedded problems from the half-completed update.

I searched for advice on GOOGLE using some appropriate terms. However, there was little or no mention of any problems with the updater, and no one seemed to be using a MacOS machine. I did find an interesting comment that suggested re-formatting the memory card before using it as the storage volume for the updater. I also resorted to launching my Macintosh into running WindowsXP. I shifted over to the Windows environment for the rest of the update process.

In WindowsXP, I ran the JAVA download app and recreated the updater package, storing it onto the newly re-formatted SD-Memory card. This went well, with no errors or retries needed. By now it was about 10 p.m. and it was pitch dark out. The mosquitos were also out. I went back to the boat with the new files on the SD-Memory card, and a flashlight.

I inserted the SD-Memory card into the HDS-8, and hit the power button. The unit came on and booted from the memory card. The updater application went into action. This time the updater proceeded through a great many more steps than it had in the past, and after several minutes the installer announced it had finished its work; my HDS-8 was ready for a reboot with its new software.

I removed the SD-Memory card and powered the HDS-8 off, then back on. It booted up and resumed normal operation. Checking the "About" section of the SYSTEM settings, the device appears to have been fully updated.

My advice to other Mac users is to create the updater memory card package using a Windows computer. You are likely to have fewer problems. I don't know if switching to Windows was the solution to the problem, or if the actual problem was cured by re-formatting the memory card. I suspect a combination of both.

When a device like a memory card is used on a MacOS machine, the operating system will write some invisible files onto the volume for meta-data and for trash recovery options. These invisible files may have been causing problems for the updater. Since I re-formatted the memory card under Windows and built the installer package onto the card without it being used to store any files from the MacOS portion of my computer, there may be some benefit from avoiding using the MacOS to manipulate files on the card prior to building the updater.

At the price of memory cards, I think I will keep the updater card I made intact, and save that memory card just for that purpose. I'll get another one or two to use for transferring screen shots and waypoints to and from the HDS-8.

SJUAE posted 08-08-2010 05:19 PM ET (US)     Profile for SJUAE  Send Email to SJUAE     
Jim--Congrats on the HDS-8. As you found in the Windows environment the application works fine and writes directly to the SD card, I have done three updates so far and had no problems. I suspect it's glitchy on MacOS due to poor programming. I also keep the update on one card and keep another blank one

I see now why you want to know what the base maps were like in another thread of yours. Did you get the standard 83/200 transducer, too ?


jimh posted 08-08-2010 07:04 PM ET (US)     Profile for jimh  Send Email to jimh     
Hi Steve--I got the 83-kHz and 200-kHz skimmer transducer. Lowrance says that combination is good to over 500-feet of depth, and in the Great Lakes there are darn few places where you can even find water that deep. If you do find water that deep there are probably no fish on the bottom to catch. About the only thing on the bottom of the Great Lakes at 500-feet deep are a few ship wrecks.
Basshole posted 08-09-2010 12:49 AM ET (US)     Profile for Basshole  Send Email to Basshole     
Jim--I also had a very difficult time updating all three of my HDS units using my MacBook Pro with [MacOS]. In fact I couldn't do it at all. Even with a Lowrance tech support person on the phone. I finally gave up and used my wife's Window's based computer and it was waaaay easier and worked perfectly. Take home message: don't use a Mac to update your HDS units, life is too short! Even the guys at Lowrance said their software is really designed to be used with Windows not MacOS. I know some people have had success using their Macs. I wouldn't even bother with it. Just find someone with a PC and save the headache.
JMR posted 08-09-2010 11:43 AM ET (US)     Profile for JMR  Send Email to JMR     
Jim: I have an HDS-8 and had the same difficulty with the MacOS-X Java, so I downloaded with a PC using XP Professional. Your comments will be welcome to all similarly afflicted and maybe Apple-Lowrance will figure out a fix. I had similar problems with my Furuno unit updates via Mac and used the PC as well.
jimh posted 08-09-2010 08:30 PM ET (US)     Profile for jimh  Send Email to jimh     
To clarify one thing I mentioned above, when I switched to a Windows environment, I downloaded a Windows executable file, not a JAVA applet, which I used to create the updater package. The move to Windows appears to skip the whole JAVA portion of the process.

I used this link to get the Windows executable file: exe

SJUAE posted 08-09-2010 08:48 PM ET (US)     Profile for SJUAE  Send Email to SJUAE     
With windows you have both options ie run online or download and run. I found the later to be more reliable especially if you have a slow connection. Regards--Steve
whale posted 08-18-2010 05:19 PM ET (US)     Profile for whale  Send Email to whale     
I tried with window 7 and install stopped halfway, then I went to vista and it worked fine. Maybe 3.0 has some bug.
jimh posted 08-21-2010 05:28 PM ET (US)     Profile for jimh  Send Email to jimh     
After the update was applied, my HDS-8 showed the following information:

PLATFORM = 56.14-3 (was 56.13-2)
LOADER = 2.1 (same)
NAVIONICS = 00.02.03_r1664 (was 00.01.06_r1312)
SERIAL NUMBER = nnnnnnnnnn
SONAR = 1.3.8 (same)
KEYPAD = 1.1.0 (same)
LANGUAGE = Standard (same)

Post New Topic  Post Reply
Hop to:

Contact Us | RETURN to ContinuousWave Top Page

Powered by: Ultimate Bulletin Board, Freeware Version 2000
Purchase our Licensed Version- which adds many more features!
© Infopop Corporation (formerly Madrona Park, Inc.), 1998 - 2000.